Bug #40159

Task #40095: Move core to namespaces

Some classes get cropped because of substrings

Added by Nicole Cordes about 8 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Indexed Search
Target version:
Start date:
2012-08-25
Due date:
% Done:

100%

TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In the indexed_search extension e.g. class tx_indexedsearch_indexer was replaced with TYPO3\\CMS\\IndexedSearch\\Controller\\SearchFormController_indexer because the plugin tx_indexedsearch was replaced first.

Associated revisions

Revision 03fe2202
Added by Nicole Cordes about 8 years ago

[BUGFIX] index_search gets corrupted after namespace changes

Due to replace order for namespace pathes class tx_indexedsearch_indexer
gets corrupted. This patch fixes the problem by renaming the wrong class
name.

Change-Id: Idec2e8146c19acaef9746c95872a266b0101f93d
Fixes: #40159
Related: #40095
Release: 6.0
Reviewed-on: http://review.typo3.org/14062
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn

History

#1 Updated by Nicole Cordes about 8 years ago

Can you please rename the issue to "index_search gets corrupted after namespace changes"

#2 Updated by Gerrit Code Review about 8 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14062

#3 Updated by Christian Kuhn about 8 years ago

  • Parent task set to #40095

#4 Updated by Nicole Cordes about 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Riccardo De Contardi almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF