Bug #40438

Install process fails on case-insensitive file systems

Added by Oliver Hader over 7 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
Start date:
2012-08-30
Due date:
% Done:

100%

TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The install process fails on case-insensitive file systems like HFS+ on Mac OS X.
The reason is that "classes" and "Classes" are the same in that regard, which will load the old saltedpasswords autoloader.
Since the extension is not enabled in the install process, this will fail of course.

Associated revisions

Revision 597838be (diff)
Added by Oliver Hader over 7 years ago

[BUGFIX] Install process fails on case-insensitive file systems

The install process fails on case-insensitive file systems like
HFS+ on Mac OS X. The reason is that "classes" and "Classes" are
the same in that regard, which will load the old saltedpasswords
autoloader. Since the extension is not enabled in the install
process, this will fail of course.

Change-Id: Ic4e9a7d4149faeb5b68ae238101d27a10c5d5f7e
Fixes: #40438
Releases: 6.0
Reviewed-on: http://review.typo3.org/14228
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

History

#1 Updated by Gerrit Code Review over 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14228

#2 Updated by Oliver Hader over 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF