Bug #41924

Faulty localization if IRRE is used on pages

Added by Oliver Hader about 7 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
FormEngine aka TCEforms
Target version:
Start date:
2012-10-12
Due date:
% Done:

100%

TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
hard
Is Regression:
Sprint Focus:

Description

Due to the fact that the pages table has it's own translation table, pages_language_overlay, localization of IRRE records is not possible there.
The fix is to use the TCA setting transOrigPointerTable (= pages_language_overlay) instead of the original parent table (= pages).

Associated revisions

Revision b0f4593d (diff)
Added by Oliver Hader about 7 years ago

[BUGFIX] Faulty localization if IRRE is used on pages

Due to the fact that the pages table has it's own translation
table, pages_language_overlay, localization of IRRE records is
not possible there.
The fix is to use the TCA setting transOrigPointerTable
(= pages_language_overlay) instead of the original parent table
(= pages).

Change-Id: I088fe01033f9cf9c35a0e979215bb378be4a3dba
Fixes: #41924
Releases: 4.5, 4.6, 4.7, 6.0
Reviewed-on: http://review.typo3.org/15523
Reviewed-by: Steffen Ritter
Reviewed-by: Georg Ringer
Tested-by: Steffen Ritter
Reviewed-by: Andreas Wolf
Reviewed-by: Helmut Hummel
Tested-by: Helmut Hummel

History

#1 Updated by Oliver Hader about 7 years ago

Use the SVN version of the IRRE tutorial to test this behaviour with any page.
https://svn.typo3.org/TYPO3v4/Extensions/irre_tutorial/trunk/

#2 Updated by Gerrit Code Review about 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/15523

#3 Updated by Oliver Hader about 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF