Bug #42281

Translated non-published page in workspace breaks live workspace

Added by Oliver Hader almost 7 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Backend API
Target version:
Start date:
2012-10-22
Due date:
% Done:

100%

TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

#1: PHP Catchable Fatal Error: Argument 2 passed to TYPO3\CMS\Backend\Utility\IconUtility::getSpriteIconForRecord() must be an array, null given, called in typo3/sysext/backend/Classes/View/PageLayoutView.php on line 585 and defined in typo3/sysext/backend/Classes/Utility/IconUtility.php line 680 (More information)

How to reproduce on master:
  • switch to some workspace
  • create a new translation of a page
  • switch back to live workspace

Associated revisions

Revision 11a52d7c (diff)
Added by Oliver Hader almost 7 years ago

[BUGFIX] Translated non-published page in workspace breaks live workspace

Translation of pages are stored in pages_language_overlay and
can be managed in workspaces as well. If a new translation is
created in the workspace only, the page module is broken in
the live workspace.

The reason for that is, that workspaces placeholders need to
be ignored if not working on a real workspace.

Change-Id: Ied52a985c3cb1c0796f616679414799d956024d8
Releases: 6.0, 4.7, 4.6, 4.5
Fixes: #42281
Reviewed-on: http://review.typo3.org/15958
Reviewed-by: Steffen Ritter
Tested-by: Steffen Ritter
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

Revision b69dc9da (diff)
Added by Oliver Hader almost 7 years ago

[BUGFIX] Translated non-published page in workspace breaks live workspace

Translation of pages are stored in pages_language_overlay and
can be managed in workspaces as well. If a new translation is
created in the workspace only, the page module is broken in
the live workspace.

The reason for that is, that workspaces placeholders need to
be ignored if not working on a real workspace.

Change-Id: Ied52a985c3cb1c0796f616679414799d956024d8
Releases: 6.0, 4.7, 4.6, 4.5
Fixes: #42281
Reviewed-on: http://review.typo3.org/16135
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

Revision 5de18077 (diff)
Added by Oliver Hader almost 7 years ago

[BUGFIX] Translated non-published page in workspace breaks live workspace

Translation of pages are stored in pages_language_overlay and
can be managed in workspaces as well. If a new translation is
created in the workspace only, the page module is broken in
the live workspace.

The reason for that is, that workspaces placeholders need to
be ignored if not working on a real workspace.

Change-Id: Ied52a985c3cb1c0796f616679414799d956024d8
Releases: 6.0, 4.7, 4.6, 4.5
Fixes: #42281
Reviewed-on: http://review.typo3.org/16136
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

Revision dba123bc (diff)
Added by Oliver Hader almost 7 years ago

[BUGFIX] Translated non-published page in workspace breaks live workspace

Translation of pages are stored in pages_language_overlay and
can be managed in workspaces as well. If a new translation is
created in the workspace only, the page module is broken in
the live workspace.

The reason for that is, that workspaces placeholders need to
be ignored if not working on a real workspace.

Change-Id: Ied52a985c3cb1c0796f616679414799d956024d8
Releases: 6.0, 4.7, 4.6, 4.5
Fixes: #42281
Reviewed-on: http://review.typo3.org/16137
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

History

#1 Updated by Oliver Hader almost 7 years ago

  • Status changed from New to Accepted

#2 Updated by Oliver Hader almost 7 years ago

  • Target version changed from 6.0.0-RC1 to 4.5.21
  • TYPO3 Version changed from 6.0 to 4.5

#3 Updated by Oliver Hader almost 7 years ago

  • Assignee set to Oliver Hader

#4 Updated by Gerrit Code Review almost 7 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/15958

#5 Updated by Gerrit Code Review almost 7 years ago

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/16135

#6 Updated by Gerrit Code Review almost 7 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/16136

#7 Updated by Gerrit Code Review almost 7 years ago

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/16137

#8 Updated by Oliver Hader almost 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#9 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF