Bug #42789

requestUpdate doesn't work if fields are separated by a space

Added by Diego Pino over 8 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Category:
FormEngine aka TCEforms
Target version:
Start date:
2012-11-08
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

I set my TCA like:

$TCA['table']['ctrl']['requestUpdate'] = 'field1, field2';

If I change the value of 'field1' in BE, a reload is requested. If I change the value of 'field2' in BE, there's no reload requested. I expect a reload request in this case too.

I noticed that if I remove the space between the fields, it works.

$TCA['table']['ctrl']['requestUpdate'] = 'field1,field2';


Related issues

Related to TYPO3 Core - Bug #49872: requestUpdate doesn't work if fields are separated by a space (redux)ClosedFrancois Suter2013-07-10

Actions
#1

Updated by Francois Suter almost 8 years ago

  • Status changed from New to Accepted
  • Assignee set to Francois Suter
  • Target version set to next-patchlevel

Indeed, this is due to \TYPO3\CMS\Core\Utility\GeneralUtility::inList() not tolerating spaces. The behaviour of that method cannot be changed easily for fear of breaking existing uses or of hurting performance (this method is used very widely). After discussion in the core mailing list, a good solution seems to be to remove spaces from "requestUpdate" upon handling it, since no spaces can be expected in that place.

I'll prepare a patch for this.

#2

Updated by Gerrit Code Review almost 8 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/22174

#3

Updated by Gerrit Code Review almost 8 years ago

Patch set 1 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/22185

#4

Updated by Gerrit Code Review almost 8 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/22186

#5

Updated by Francois Suter almost 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#6

Updated by Gerrit Code Review almost 8 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at https://review.typo3.org/22187

#7

Updated by Gerrit Code Review almost 8 years ago

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at https://review.typo3.org/22188

#8

Updated by Francois Suter almost 8 years ago

  • Status changed from Under Review to Resolved
#9

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF