Bug #43041

Extension Manager doesn't care about Configuration sorting

Added by Nicole Cordes over 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extension Manager
Target version:
Start date:
2012-11-17
Due date:
% Done:

100%

TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When showing the configuration of an extension actually the Extension Manager doesn't care about the given sorting.

E.g. configuration:

  1. cat=basic/enable/10; type=boolean; label=First configuration option
    firstOption = 1
  1. cat=basic/enable/20; type=int; label=Second option
    secondOption = 999

The sorting is the other way around because configuration is just merged.

Associated revisions

Revision 328165f1 (diff)
Added by Nicole Cordes about 7 years ago

[BUGFIX] Extension Manager doesn't care about configuration sorting

When showing the configuration of an extension actually the Extension
Manager doesn't care about the given sorting. This is because there is
only a merging of configuration arrays.

After merging we have to take care of the value in 'subcat' key and sort
each subcategorie by those values.

Change-Id: Idb27554be40603c4af7e0506f039d0c0416a0d9a
Fixes: #43041
Releases: 6.0
Reviewed-on: http://review.typo3.org/16502
Reviewed-by: Philipp Gampe
Tested-by: Philipp Gampe
Reviewed-by: Wouter Wolters
Tested-by: Wouter Wolters
Reviewed-by: Stefan Neufeind
Tested-by: Stefan Neufeind
Reviewed-by: Helmut Hummel
Tested-by: Helmut Hummel

History

#1 Updated by Gerrit Code Review over 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16502

#2 Updated by Gerrit Code Review over 7 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16502

#3 Updated by Gerrit Code Review about 7 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16502

#4 Updated by Gerrit Code Review about 7 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16502

#5 Updated by Nicole Cordes about 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF