Bug #43126

Some unit tests fail in Core::LocalDriverTest

Added by Nicole Cordes over 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Tests
Target version:
Start date:
2012-11-20
Due date:
% Done:

100%

TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Some tests (especially permission tests) fail in Core::LocalDriverTest. As there doesn't seem to be any solution for file permissions we have to skip those tests on Windows system. For other the Windows fix /conversion from backslashes to forward slashes) has to be integrated.

Please set the parent task to #40005

Associated revisions

Revision 18c428bc (diff)
Added by Nicole Cordes over 7 years ago

[BUGFIX] Some unit tests fail in Core::LocalDriverTest

Some tests fail on Windows systems. Mostly this is because of a missing
file and folder permission handling. Those tests have to be skipped.
Furthermore there is some path fixing needed in basic class.

Change-Id: Ib89e84539af2742dbb3a6e2f53ae5a0c121a0626
Fixes: #43126
Release: 6.0
Reviewed-on: http://review.typo3.org/16596
Reviewed-by: Oliver Klee
Reviewed-by: Jigal van Hemert
Tested-by: Jigal van Hemert
Reviewed-by: Philipp Gampe
Tested-by: Philipp Gampe
Reviewed-by: Wouter Wolters
Tested-by: Wouter Wolters
Reviewed-by: Helmut Hummel
Tested-by: Helmut Hummel

History

#1 Updated by Gerrit Code Review over 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16596

#2 Updated by Gerrit Code Review over 7 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16596

#3 Updated by Gerrit Code Review over 7 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16596

#4 Updated by Nicole Cordes over 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF