Bug #43139

Activating NULL value field does not work with blank string

Added by Oliver Hader almost 7 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Backend API
Target version:
Start date:
2012-11-20
Due date:
% Done:

100%

TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Activating a field that supports NULL values and just using a blank string ("") does not work.
The problem is a strcmp() call that returns a false-positive on comparing NULL to blank strings.


Related issues

Related to TYPO3 Core - Feature #41773: Add possibility to store NULL values Closed 2012-10-09

Associated revisions

Revision 125bdf9e (diff)
Added by Oliver Hader almost 7 years ago

[BUGFIX] Activating NULL value field does not work with blank string

Activating a field that supports NULL values and just using a
blank string ("") does not work. The problem is a strcmp() call
that returns a false-positive on comparing NULL to blank strings

Change-Id: I59417f5f5cd814db15e2b6b725f1778d098014f6
Fixes: #43139
Releases: 6.0
Reviewed-on: http://review.typo3.org/16599
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

History

#1 Updated by Gerrit Code Review almost 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16599

#2 Updated by Gerrit Code Review almost 7 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16599

#3 Updated by Oliver Hader almost 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF