Bug #43183

Placeholder JavaScript handling is active for Non-IE browsers

Added by Oliver Hader almost 7 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Backend User Interface
Target version:
Start date:
2012-11-21
Due date:
% Done:

100%

TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The jsfunc.placeholder.js file was introduced to have a fallback for Internet Explorer on the HTML5 placeholder feature.
However, this handling is currently active in all browsers and results in broken NULL values for textarea, since textarea don't have a human readable representation like input fields (the field_hr clones).

Thus, only activate the handling in Internet Explorer.

Associated revisions

Revision 037f36dd (diff)
Added by Oliver Hader almost 7 years ago

[BUGFIX] Placeholder JavaScript handling is active for Non-IE browsers

The jsfunc.placeholder.js file was introduced to have a fallback
for Internet Explorer on the HTML5 placeholder feature. However,
this handling is currently active in all browsers and results in
broken NULL values for textarea, since textarea don't have a
human readable representation like input fields.

Fixes: #43183
Releases: 6.0
Thus, only activate the handling in Internet Explorer.

Change-Id: Ie27c8e8544fa99cad14f3a74fa960524cc7e834a
Reviewed-on: http://review.typo3.org/16644
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

History

#1 Updated by Gerrit Code Review almost 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16644

#2 Updated by Oliver Hader almost 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF