Bug #43434

Extension names with zip files eg. myextension_1.0.0(1).zip

Added by Dietrich Heise about 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extension Manager
Target version:
-
Start date:
2012-11-29
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hi,

if I upload an zip file via the extensionmanager, the zip name is used for the upload directory and extension name.

So if you download an extension as zip file twice, the os will rename the second file.

For example, first downloaded file:
myextension_1.0.0.zip
if you download the extension the second time, the extension is named:
myextension_1.0.0(1).zip
If you now upload the extension with (1) in the name the installation is broken, a directory myextension(1) with the extension content will be created.

#1

Updated by Jan Kornblum almost 9 years ago

I've also just run into this problem.

In addition, using the download-button in extension manager should again create a filename containing a timestamp (as old extension manager used to do). But only after the upload-problem as above has been fixed ;)

#2

Updated by Oliver Hader almost 9 years ago

  • Target version set to 2222
#3

Updated by Oliver Hader almost 9 years ago

  • Project changed from 2269 to TYPO3 Core
#4

Updated by Oliver Hader almost 9 years ago

  • Category set to Extension Manager
#5

Updated by Oliver Hader almost 9 years ago

  • Target version deleted (2222)
#6

Updated by Felix Kopp almost 9 years ago

The (1) suffix is added by your browser or OS.
Please delete the already downloaded extension archive before.

Extension manager always sets the archive export name by one convention.
This is not an issue for the extension manager code.

I will close the issue for now.
Thank you for your hint!

#7

Updated by Felix Kopp almost 9 years ago

  • Status changed from New to Closed
#8

Updated by Felix Kopp almost 9 years ago

We found a different bug due to your report - thank you!

Also available in: Atom PDF