Bug #44537

BackendUtility::displayWarningMessages uses wrong returnUrl

Added by Sebastian Michaelsen almost 7 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2013-01-15
Due date:
% Done:

100%

TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Steps to reproduce:
  • create a user with the following credentials: admin/password (you're encouraged not to do so on a live system ;) )
  • open the "About Modules" module, which shows a warning about the admin user.
  • click the link to edit the admin user
  • close or save/close the form
  • 404

Bildschirmfoto_2013-01-24_um_12.42.36.png View (40.7 KB) Sebastian Michaelsen, 2013-01-24 12:43

Associated revisions

Revision ed3651f4 (diff)
Added by Sebastian Michaelsen over 6 years ago

[BUGFIX] displayWarningMessages uses wrong returnUrl

The warning in the "About Modules" module about an
insecure admin offers a link to edit this user. Following
this link and then closing the form again leads to a 404.
The reason is a wrong returnUrl in
BackendUtility:: displayWarningMessages.

Resolves: #44537
Releases: 6.1, 6.0
Change-Id: I41d361d8b7314ac0bace8b8a5979a6f69128657c
Reviewed-on: https://review.typo3.org/17543
Reviewed-by: Mattias Nilsson
Reviewed-by: Wouter Wolters
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn

Revision 8ff93ace (diff)
Added by Sebastian Michaelsen over 6 years ago

[BUGFIX] displayWarningMessages uses wrong returnUrl

The warning in the "About Modules" module about an
insecure admin offers a link to edit this user. Following
this link and then closing the form again leads to a 404.
The reason is a wrong returnUrl in
BackendUtility:: displayWarningMessages.

Resolves: #44537
Releases: 6.1, 6.0
Change-Id: I41d361d8b7314ac0bace8b8a5979a6f69128657c
Reviewed-on: https://review.typo3.org/17875
Reviewed-by: Christian Kuhn
Tested-by: Christian Kuhn

History

#1 Updated by Gerrit Code Review over 6 years ago

  • Status changed from New to Under Review

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/17543

#3 Updated by Gerrit Code Review over 6 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/17875

#4 Updated by Sebastian Michaelsen over 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF