Bug #45415

Content adapter sets imagecaption of media field instead of image field

Added by Helmut Hummel about 7 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2013-02-12
Due date:
% Done:

100%

TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Problem:
Create a new content element of type file links, add a file relation and a description to this file.
Switch this element to be an image element, add an image and a description of the image

Expected result:
An image with the image description is shown

Actual result:
An image with the description of the file is shown.


Related issues

Related to TYPO3 Core - Bug #46067: Image rendering fails when using 'image' or 'media' field with own CEs (CType) Closed 2013-03-06

Associated revisions

Revision 8fe18b16 (diff)
Added by Helmut Hummel almost 7 years ago

[BUGFIX] Do not overwrite imagecaption in content adapter

Problem:
Create a new content element of type file links,
add a file relation and a description to this file.
Switch this element to be an image element,
add an image and a description of the image

Expected result:
An image with the image description is shown

Actual result:
An image with the description of the file is shown.

Solution:
Check if the field actually is shown in the selected
content element type.

Fixes: #45415
Releases: 6.0, 6.1

Change-Id: I3aa0e47b336cfa881c637b7f5a9e68476ded88ae
Reviewed-on: https://review.typo3.org/18222
Reviewed-by: Wouter Wolters
Tested-by: Wouter Wolters
Reviewed-by: Helmut Hummel
Tested-by: Helmut Hummel

Revision ac951d12 (diff)
Added by Helmut Hummel almost 7 years ago

[BUGFIX] Do not overwrite imagecaption in content adapter

Problem:
Create a new content element of type file links,
add a file relation and a description to this file.
Switch this element to be an image element,
add an image and a description of the image

Expected result:
An image with the image description is shown

Actual result:
An image with the description of the file is shown.

Solution:
Check if the field actually is shown in the selected
content element type.

Fixes: #45415
Releases: 6.0, 6.1

Change-Id: I3aa0e47b336cfa881c637b7f5a9e68476ded88ae
Reviewed-on: https://review.typo3.org/18222
Reviewed-by: Wouter Wolters
Tested-by: Wouter Wolters
Reviewed-by: Helmut Hummel
Tested-by: Helmut Hummel
Reviewed-on: https://review.typo3.org/18699

Revision d62550e9 (diff)
Added by Helmut Hummel almost 7 years ago

[BUGFIX] Fix warning in adapter service

The merge of #45415 introduced a warning
because the new meta column name was
used as array key.

Skip this step when the meta column
is found to fix this issue.

Fixes: #45415
Releases: 6.1, 6.0

Change-Id: I5446104359816d0ccacf6c239b86b9b073783174
Reviewed-on: https://review.typo3.org/18700
Reviewed-by: Helmut Hummel
Tested-by: Helmut Hummel

Revision 036ed56d (diff)
Added by Helmut Hummel almost 7 years ago

[BUGFIX] Fix warning in adapter service

The merge of #45415 introduced a warning
because the new meta column name was
used as array key.

Skip this step when the meta column
is found to fix this issue.

Fixes: #45415
Releases: 6.1, 6.0

Change-Id: I5446104359816d0ccacf6c239b86b9b073783174
Reviewed-on: https://review.typo3.org/18700
Reviewed-by: Helmut Hummel
Tested-by: Helmut Hummel
Reviewed-on: https://review.typo3.org/18701

History

#1 Updated by Gerrit Code Review about 7 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/18222

#2 Updated by Gerrit Code Review about 7 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/18222

#3 Updated by Gerrit Code Review about 7 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/18222

#4 Updated by Gerrit Code Review about 7 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/18222

#5 Updated by Gerrit Code Review almost 7 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/18699

#6 Updated by Anonymous almost 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Gerrit Code Review almost 7 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/18700

#8 Updated by Gerrit Code Review almost 7 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/18701

#9 Updated by Anonymous almost 7 years ago

  • Status changed from Under Review to Resolved

#10 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF