Bug #45787

Unknown column 'module' in 'field list'

Added by Tomasz Krawczyk about 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2013-02-24
Due date:
% Done:

0%

TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I upgraded site from 4.7.4 to 6.0.2. So, I had to execute Database Compare function.
Then I executed updating extension list from Scheduler and I saw such error message at the bottom of BE:

exec_INSERTmultipleRows
caller TYPO3\CMS\Core\Database\DatabaseConnection::exec_INSERTmultipleRows
ERROR Unknown column 'module' in 'field list'

...and long list where the only suspicious was:

"1361549498, '01f4d6d531b25651910539db22b68cd9', 1, 999, 0, module, 'Upload"

The table tx_extensionmanager_domain_model_extension has no "module" field. The variable or constant module appears a few times in command string. It may cause the error message.

I attached two screenshots.

em_screen_1.png View - Begin of the error message (28.3 KB) Tomasz Krawczyk, 2013-02-24 10:48

em_screen_2.png View - The "module" (5.81 KB) Tomasz Krawczyk, 2013-02-24 10:48


Related issues

Related to TYPO3 Core - Bug #47870: Sql error during TER update import process. Closed 2013-05-03
Duplicates TYPO3 Core - Bug #41620: Extension-Manager fails updating the Extension List on a fresh Installation Rejected 2012-10-05

History

#1 Updated by Michael Stucki almost 7 years ago

  • Status changed from New to Needs Feedback

Can you check if any of your installed extensions causes this? You can check this by disabling each of them...

#2 Updated by Tomasz Krawczyk almost 7 years ago

Michael I never used any extension that changes Extension Manager. BTW EM is the only extension I know that inserts records to the table tx_extensionmanager_domain_model_extension.

I upgraded my installation to TYPO3 6.0.3, removed all records from the table tx_extensionmanager_domain_model_extension and downloaded extensions list again. Now I have no problem.

#3 Updated by Christian Kuhn almost 7 years ago

  • Status changed from Needs Feedback to Closed

dupe of #41620

#4 Updated by Tomasz Krawczyk almost 7 years ago

Guys,

please, reopen this bugreport. I've just noticed that this error shows when extension list is upgraded from Scheduler. From the Extension Manager everything is OK.

#5 Updated by Christian Kuhn almost 7 years ago

No, the issue was in em, too (you just didn't see the error msg). It was fixed with the related issue and will be released with next 6.0 minor version.

#6 Updated by Laurent Cherpit almost 7 years ago

It seems that is really a little extension manager bug. and not a duplicate of #41620

#7 Updated by Laurent Cherpit almost 7 years ago

It seems that is really a little extension manager bug. and not a duplicate of #41620.
take a look at #47870 issue.

Also available in: Atom PDF