Bug #46535

Image rendering of non-existing files throws exception

Added by Oliver Hader about 8 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2013-03-22
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Rendering an image that has no accordant file in a storage in the frontend (e.g. in TypoScript) fails with an exception like "Object with identifier xyz does not exist in storage" (1329647780).

Sure, the file does not exist in that case, but throwing an exception that is not caught is too much.
Besides that $cObj->getImgResource() already catches \TYPO3\CMS\Core\Resource\Exception - which does not cover RuntimeExceptions.

Solution:
Throw a \TYPO3\CMS\Core\Resource\Exception instead of a RuntimeException in these cases. A new ResourceDoesNotExistException is introduced to cover files and folders.


Related issues

Related to TYPO3 Core - Bug #37409: Page Module unuseable if resource is missing due to exceptionClosed2012-05-23

Actions
Is duplicate of TYPO3 Core - Bug #45779: Blank page/Exception when referenced images are deleted in filesystemClosed2013-02-23

Actions
#1

Updated by Gerrit Code Review about 8 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19168

#2

Updated by Gerrit Code Review about 8 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19168

#3

Updated by Gerrit Code Review about 8 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/19393

#4

Updated by Oliver Hader about 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#5

Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF