Bug #46836

Clipboard fails on renaming resource

Added by Oliver Hader over 6 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2013-04-01
Due date:
% Done:

0%

TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Scenario:
  • put a file or folder to clipboard in file list view (e.g. copy or cut)
  • rename that very file or folder
  • see the exception like "#1329647780: Object with identifier "1:/something/oldxxx/9101.tif" does not exist in storage"

Thus, the clipboard should either work on an numeric identified (uid) or catch that exception.

History

#1 Updated by Sebastian Fischer over 5 years ago

This seems to be fixed by removing the item from the clipboard in the moment the file gets renamed. You need to readd it to the clipboard again, but no exception gets thrown.

#2 Updated by Markus Klein over 4 years ago

  • Status changed from New to Closed
  • Is Regression set to No

Works on 6.2.11+

Also available in: Atom PDF