Bug #46866

wrong image extensions

Added by Tomasz Krawczyk over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2013-04-02
Due date:
% Done:

0%

TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Images created by FE have wrong extensions.

Reproduce steps:
  1. add "Text & Images" CE
  2. add some jpeg images on the Images sheet
  3. go to Appearance sheet and select "Quality and Type" value "PNG/256"
  4. select effect f.e. Brighter
  5. save and preview in the FE. Looks OK but in the processed directory file created is csm_*.jpg. Should be csm_*.png.

Files created are PNGs but the ext is wrong.

My TYPO3 version is 6.0.4.


Related issues

Related to TYPO3 Core - Bug #46530: Crop-Scaled images have wrong file content type Closed 2013-03-29 2013-03-29
Related to TYPO3 Core - Bug #43624: Gifbuilder cannot generate images Closed 2012-12-05

History

#1 Updated by Felix Kopp over 6 years ago

This bug seems to be connected to #46530.
Please check if the bug still can be reproduced on master (or later on 6.0.5).

Thank you!

#2 Updated by Felix Kopp over 6 years ago

  • Status changed from New to Needs Feedback

#3 Updated by Stefan Neufeind over 6 years ago

@Tomasz: Since 6.0.5-rc1 is out, could you maybe try to upgrade to that and see if your bug is resolved? Then this report sounds like a dupe of the bug Felix mentioned.

#4 Updated by Chris topher over 6 years ago

#43624 seems to be different, but the same kind of problem.

#5 Updated by Tomasz Krawczyk over 6 years ago

I checked this on 6.0.5 rc1 and it looks it works now as expected.

#6 Updated by Felix Kopp over 6 years ago

  • Status changed from Needs Feedback to Closed

Also available in: Atom PDF