Bug #46530

Crop-Scaled images have wrong file content type

Added by Oliver Hader over 6 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2013-03-29
Due date:
2013-03-29
% Done:

100%

TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
medium
Is Regression:
Sprint Focus:

Description

The following scenario is given:
  • resize a 300dpi TIFF image to PNG using stdWrap/cObj
  • the 'fileExtension' configuration is not set ($fileArray['ext'] is empty)
  • the processed file csm_... has the file extension PNG
  • but the file content type is still TIFF, so the file was just renamed, but not converted to PNG

Solution:
Since the processing task determines the accordant filename and file extension, the image processor (ImageMagick, ...) needs to know about that fact as well.


Related issues

Related to TYPO3 Core - Bug #44571: FE pdf thumbnail generation fails Closed 2013-01-16
Related to TYPO3 Core - Bug #46866: wrong image extensions Closed 2013-04-02
Related to TYPO3 Core - Bug #43624: Gifbuilder cannot generate images Closed 2012-12-05
Duplicates TYPO3 Core - Bug #45383: Rendering of TIFF images broken Closed 2013-02-11
Follows TYPO3 Core - Bug #46737: Mask images have wrong file content type Closed 2013-03-28

Associated revisions

Revision 7b655915 (diff)
Added by Oliver Hader over 6 years ago

[!!!][BUGFIX] Crop-Scaled images have wrong file content type

The following scenario is given:
  • resize a 300dpi TIFF image to PNG using stdWrap/cObj
  • the 'fileExtension' configuration is not set
  • the processed file csm_... has the file extension PNG
  • but the file content type is still TIFF, so the file
    was just renamed, but not converted to PNG

Since the processing task determines the accordant filename
and file extension of the processed file, the image processor
(e.g. ImageMagick) needs to know about that fact as well.

This change modifies the TaskInterface which is rarely to not
at all used in custom extensions implementing individual tasks
to process files.

Change-Id: I089edc01a39663ac91b1b9df168f659c32954fcb
Fixes: #46530
Releases: 6.0, 6.1
Reviewed-on: https://review.typo3.org/19169
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

Revision 106cd209 (diff)
Added by Oliver Hader over 6 years ago

[!!!][BUGFIX] Crop-Scaled images have wrong file content type

The following scenario is given:
  • resize a 300dpi TIFF image to PNG using stdWrap/cObj
  • the 'fileExtension' configuration is not set
  • the processed file csm_... has the file extension PNG
  • but the file content type is still TIFF, so the file
    was just renamed, but not converted to PNG

Since the processing task determines the accordant filename
and file extension of the processed file, the image processor
(e.g. ImageMagick) needs to know about that fact as well.

This change modifies the TaskInterface which is rarely to not
at all used in custom extensions implementing individual tasks
to process files.

Change-Id: I089edc01a39663ac91b1b9df168f659c32954fcb
Fixes: #46530
Releases: 6.0, 6.1
Reviewed-on: https://review.typo3.org/19169
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader
Reviewed-on: https://review.typo3.org/19397

History

#1 Updated by Gerrit Code Review over 6 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19169

#2 Updated by Gerrit Code Review over 6 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19169

#3 Updated by Gerrit Code Review over 6 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/19397

#4 Updated by Oliver Hader over 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF