Bug #47145

TypoScript stripProfile not forwarded to ProcessedFile

Added by Oliver Hader over 6 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2013-04-11
Due date:
% Done:

100%

TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

The TypoScript stripProfile feature not forwarded to
ProcessedFile anymore. Example of the feature that has
been available in TYPO3 CMS 4.x:

10 = IMAGE
10.file = fileadmin/images/image1.jpg
10.file.stripProfile = 1

The protected method modifyImageMagickStripProfileParameters()
does not make any sense anymore since the actual ImageMagick
processing has been moved around in TYPO3 CMS 6.0.

Associated revisions

Revision e26578f1 (diff)
Added by Oliver Hader over 6 years ago

[BUGFIX] TypoScript stripProfile not forwarded to ProcessedFile

The TypoScript stripProfile feature not forwarded to
ProcessedFile anymore. Example of the feature that has
been available in TYPO3 CMS 4.x:

10 = IMAGE
10.file = fileadmin/images/image1.jpg
10.file.stripProfile = 1

The protected method modifyImageMagickStripProfileParameters()
does not make any sense anymore since the actual ImageMagick
processing has been moved around in TYPO3 CMS 6.0.

Fixes: #47145
Releases: 6.0, 6.1
Change-Id: If9a36def32327d3fc610b5f4ebc998bee2babf49
Reviewed-on: https://review.typo3.org/19814
Reviewed-by: Georg Ringer
Tested-by: Georg Ringer

Revision 00c8f0c5 (diff)
Added by Oliver Hader over 6 years ago

[BUGFIX] TypoScript stripProfile not forwarded to ProcessedFile

The TypoScript stripProfile feature not forwarded to
ProcessedFile anymore. Example of the feature that has
been available in TYPO3 CMS 4.x:

10 = IMAGE
10.file = fileadmin/images/image1.jpg
10.file.stripProfile = 1

The protected method modifyImageMagickStripProfileParameters()
does not make any sense anymore since the actual ImageMagick
processing has been moved around in TYPO3 CMS 6.0.

Fixes: #47145
Releases: 6.0, 6.1
Change-Id: If9a36def32327d3fc610b5f4ebc998bee2babf49
Reviewed-on: https://review.typo3.org/19814
Reviewed-by: Georg Ringer
Tested-by: Georg Ringer
Reviewed-on: https://review.typo3.org/19957
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

History

#1 Updated by Oliver Hader over 6 years ago

  • Subject changed from TypoScript stripProfile feature missing in ProcessedFile to TypoScript stripProfile feature not forwarded to ProcessedFile

#2 Updated by Oliver Hader over 6 years ago

  • Subject changed from TypoScript stripProfile feature not forwarded to ProcessedFile to TypoScript stripProfile not forwarded to ProcessedFile

#3 Updated by Gerrit Code Review over 6 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19814

#4 Updated by Oliver Hader over 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Gerrit Code Review over 6 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/19957

#6 Updated by Oliver Hader over 6 years ago

  • Status changed from Under Review to Resolved

#7 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF