Bug #47239

Form and table wizard icon only appears after CE has been saved

Added by Jozef Spisiak over 8 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2013-04-15
Due date:
% Done:

10%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Might be related to a very old bug: #18021

Steps how to reproduce:
a) Install Blank Package 6.0.4
b) Login to Backend
c) Use New content element wizard (plus on the page content element area) on page Home to select Table or Form element
d) In tab where should be the wizard icon is just plain textarea without any wizard icon

Workaround:
Save content element and the wizard icon appears.

#1

Updated by Jan Spisiak over 8 years ago

  • % Done changed from 0 to 10

typo3/sysext/cms/tbl_tt_content.php

'wizards' => array(
    ...
    'table' => array(
        'notNewRecords' => 1,
        ...
    ),
    'forms' => array(
        'notNewRecords' => 1,
        ...
    )
),

typo3/sysext/form/ext_tables.php

$TCA['tt_content']['columns']['bodytext']['config']['wizards']['forms'] = array(
    'notNewRecords' => 1,
    ...
);

Setting these values to 0 seems to fix the problem for Table Wizard and Mail Wizard.. but I am not sure what was intended with setting them to 1.

#2

Updated by Jan Spisiak over 8 years ago

Actually, before I didn't try to use it, and realized now that Wizard can't work without the record for that CE being created before. So you would have to have record created for that CE when you click on wizard, or otherwise it won't work.

#3

Updated by Andreas Keck almost 8 years ago

What is the current state of this Bug?

#4

Updated by Jozef Spisiak almost 8 years ago

Hi.

Sorry for late reply, I was on vacation. Bug can be still replicated on the introduction package 6.1.7.

#5

Updated by Mathias Schreiber over 6 years ago

  • Status changed from New to Closed
  • Is Regression set to No
I'm closing this one down.
Not because it's not valid, but because this is something inherited so deep in FormEngine.
Here are some other variations of that report:
  • Changing a CType causes forms to be reloaded
  • Changing typeFields require a reload

In order to make this work we need to rebuild FormEngine so it can reloadForms via AJAX.

We have this on our agenda.

Also available in: Atom PDF