Bug #47332

Something was wrong with FORM CE

Added by Stefan Froemken about 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
Start date:
2013-04-17
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
medium
Is Regression:
Sprint Focus:

Description

Hello Core-Team,

I don't get a contentelement of type FORM to send mails. I get no mail with and without installing sys_ext "form". I have tested mail sending from INSTALL_TOOL and it works without any problems. I have also tried to send mails over smtp. It does not work on my local machine and does not work online.
Further the recipient was saved in table col "subheader". Please switch to doctype "html5" and you will see your email address on your website!!! Switch back to trans_xhtml and the mail hides again.

I think there is basically something wrong with FORM CE.

Stefan

#1

Updated by Stefan Froemken about 8 years ago

I just have test it on a third page. There are some differents I can see with firebug:

Working Page:

index.php?id=36
POST
200
OK
text/html
Other
12.9 KB
12.5 KB
388 ms
366 ms

Problem page:

index.php?id=15
sfroemken.de
POST
301
Moved Permanently
text/html
Other
532 B
0 B
86 ms
86 ms

I don't understand why it was realized with HTTP-Header 301.

I have read out $_POST. But it was empty.

Stefan

#2

Updated by Stefan Froemken about 8 years ago

I have it. These 2 lines are the problem:

RewriteCond %{HTTP_HOST} ^sfroemken\.de$ [NC]
RewriteRule ^(.*)$ http://www.sfroemken.de/$1 [R=301,L]

After deactivating this lines the Form works again.

Stefan

#3

Updated by Alexander Opitz about 8 years ago

  • Status changed from New to Closed

This looks like your Domain Record isn't set (or is set false).

Anyway, your Rewrite rule says, if Domain starts with sfroemken.de, the redirect the user to http://www.sfroemken.de/$1 with status code 301.

So no TYPO3 CMS Bug => close.

Also available in: Atom PDF