Bug #47354

Make DBgetDelete() update tstamp on delete by update

Added by Stefan Neufeind about 8 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2013-04-18
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.1
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In ContentObjectRenderer::DBgetDelete() it is possible that TCA for a table instructs TYPO3 to not really delete the row but only mark it as deleted. If that happens an "update" is performed - and thus the tstamp (if present) should be updated as well to be able to see which rows were (recently) modified/deleted.

This is the case since "forever" (at least 4.5, but surely longer). Thus if we decide to change this behavious, we should maybe also do so for master or maybe in 6.1 but not too much further down. It's imho not a "hard" behaviour-breaking change since until now you could not rely on tstamp being updated - and now the row will be visible as recently changed. But it's a behaviour-change after all.

#1

Updated by Gerrit Code Review about 8 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/20024

#2

Updated by Gerrit Code Review about 8 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/20024

#3

Updated by Gerrit Code Review almost 8 years ago

Patch set 1 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/22286

#4

Updated by Stefan Neufeind almost 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#5

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF