Bug #47966

User settings can only save password and text to DB

Added by Philipp Gampe about 8 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Backend API
Target version:
-
Start date:
2013-05-05
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
5.4
Tags:
Complexity:
medium
Is Regression:
Sprint Focus:

Description

The user settings module has its own configuration.
http://docs.typo3.org/typo3cms/CoreApiReference/UserSettingsConfiguration/Columns/Index.html

The property 'table' => 'be_users' allows to save the value of a field to DB in addition to saving it in the UC array.

This currently only works for types password and text, because only for those an additional '[be_users]' is added to the form input element property "name".

I do not consider this critical enough to port the bug to 4.x.

#1

Updated by Gerrit Code Review about 8 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/20542

#2

Updated by Gerrit Code Review about 8 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/20542

#3

Updated by Gerrit Code Review almost 8 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/20542

#4

Updated by Gerrit Code Review almost 8 years ago

Patch set 1 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/21976

#5

Updated by Gerrit Code Review almost 8 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/21977

#6

Updated by Philipp Gampe almost 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 80 to 100
#7

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF