Bug #48216

Error in RteMagicImagesUpdateWizard.php

Added by Christian Wellinghorst about 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2013-05-15
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.1
PHP Version:
Tags:
Complexity:
no-brainer
Is Regression:
Sprint Focus:

Description

The Update of Magic Images did not work correctly for me when upgrading a local test site from 4.5.25 to 6.1.

The images were correctly moved from uploads/ to fileadmin/_migrated_/RTE, but the database was not updated.

I found two issues within /typo3/sysext/install/Classes/Updates/RteMagicImagesUpdateWizard.php - function findMagicImagesInOldLocation returns the old image locations from sys_refindex. The field name for the table is "tablename", yet the "performUpdate" function uses "table" as index in two locations. In addition, the fileadmin path was omitted when updating the specific tables. The following fixes worked for me:

Replace line 163 with:
$targetRecord = $GLOBALS['TYPO3_DB']->exec_SELECTgetSingleRow('uid, ' . $targetFieldName, $refRecord['tablename'], 'uid=' . intval($refRecord['recuid']));

Replace line 166 with:
$targetRecord[$targetFieldName] = str_replace($sourceFileName, $fileadminDirectory.$targetFileName, $targetRecord[$targetFieldName]);

Replace line 168 with:
$refRecord['tablename'],

Kind regrds,
Christian


Related issues

Related to TYPO3 Core - Bug #46614: Migration wizard for RTE magic images is missingClosedBenni Mack2013-03-23

Actions
Is duplicate of TYPO3 Core - Bug #47998: RTEmagic upgrade wizard fails and uses wrong directoryClosedStefan Galinski2013-05-06

Actions
#1

Updated by Stefan Galinski about 8 years ago

  • Status changed from New to Closed

Duplicate of #47998 which is already in the review process. Would be glad if you can review the patch. :-)

Also available in: Atom PDF