Bug #48777

some images missing or swapped after update 4.5 -> 6.1.1

Added by Christian Boltz over 7 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2013-06-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.1
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I'm trying to update a website from Typo3 4.5.x to 6.1.1

In the install tool, I get the following warnings while doing the upgrade:

Upgrade Wizard:
Step 3 - Perform updates

Migrate all file relations from tt_content.image and pages.media
Update successful!

File 'uploads/pics/81d8165a33_23_67_font.png' does not exist. Referencing field: tt_content.67.image. The reference was not migrated.

File 'uploads/pics/0fd3e52a0e_23_68_font.png' does not exist. Referencing field: tt_content.68.image. The reference was not migrated.

File 'uploads/pics/c6601359f6_23_69_font.png' does not exist. Referencing field: tt_content.69.image. The reference was not migrated.

File 'uploads/pics/5cd917c4fe_23_70_font.png' does not exist. Referencing field: tt_content.70.image. The reference was not migrated.

File 'uploads/pics/6c55a918b2_23_71_font.png' does not exist. Referencing field: tt_content.71.image. The reference was not migrated.

File 'uploads/pics/5c7a80fb3c_23_72_font.png' does not exist. Referencing field: tt_content.72.image. The reference was not migrated.

File 'uploads/pics/4d4bb1490a_23_73_font.png' does not exist. Referencing field: tt_content.73.image. The reference was not migrated.

File 'uploads/pics/9129a09df1_23_74_font.png' does not exist. Referencing field: tt_content.74.image. The reference was not migrated.

(and some more, similar lines)

The result is that some pictures are missing, some are randomly(?) replaced and some appear 3 times instead of once.

If you want to see it yourself - www.suedpfalz-verlag.de is the working version (still 4.2, but updating to 4.5 works without problems), and spverlag.cboltz.de is the broken version after the update.

If you want me to test something - I can easily restore the 4.5 version from backup and do another update.

#1

Updated by Christian Boltz over 7 years ago

I tested a bit more with step-by-step updates to reduce the involved code changes.

This bug happens on the update from 4.7.12 to 6.0.6. I hope that makes finding this bug a bit easier for you ;-)

#2

Updated by Chris topher over 7 years ago

Hi Christian,

the problem is that these references are broken. Can you investigate, where they were broken?

For example for your first line:

In 6.0.6 it is broken. What about 4.7.x? Is the image uploads/pics/81d8165a33_23_67_font.png displayed properly in content element number 67? E.g. in the Backend when you edit the element? And - after you removed all temporary images from typo3temp/ and its subfolders - in the FE?

#3

Updated by Mathias Schreiber about 6 years ago

  • Status changed from New to Closed
  • Is Regression set to No

no feedback, assuming to be closed

Also available in: Atom PDF