Bug #49273

Problems using rsaauth with openssl on Windows

Added by Michael Stucki almost 8 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2013-06-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.1
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

This bug is just to document a problem that can happen when running rsaauth on a Windows system.

Problem: A Windows system complains about openssl even though it is installed and enabled:

  • RSA authentication could not detect the openssl PHP extension. Currently RSA authentication uses a command line openssl utility. This is slower and less secure. Please, consider installing openssl PHP extension.

One possible reason for this has been described in the following (German) article:
http://blog.joergboesche.de/xampp-1-7-7-apachephp-openssl-modul-workaround-gegen-abstuerze


Related issues

Related to TYPO3 Core - Bug #31188: rsaauth only checks if key generation works on WindowsClosedHelmut Hummel2011-10-22

Actions
#1

Updated by Michael Stucki almost 8 years ago

IMHO there's not much to do about it, the problem is caused by the underlying system.

TYPO3 could issue a more descriptive warning and link to this issue here.

#2

Updated by Nicole Cordes almost 7 years ago

  • Status changed from New to Closed
  • Is Regression set to No

Just for documentation:

On Windows you need an openssl installation which is able to create keys.

I've tested the following szenarios:

Apache 2.2 with PHP 5.3 / PHP 5.4 and openssl 0.9.8
Apache 2.4 (VC10) with PHP 5.4 and openssl 0.9.8
Apache 2.4 (VC11) with PHP 5.5 and openssl 1.0.1

Besides you need a system environment variable OPENSS_CONF which points to your Apache openssl.cnf (e.g: C:\Apache24\conf\openssl.cnf)

If you have further problems/questions just contact me.

Also available in: Atom PDF