Project

General

Profile

Actions

Bug #50707

closed

TCA -> selectedListStyle not respected by buttons

Added by Gone With the Wind over 10 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Category:
Backend User Interface
Target version:
Start date:
2013-08-02
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.1
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The custom width "selectedListStyle" in a TCA is not respected by the arrows next to it (see screenshot).

Tested on:
TYPO3 6.1.2, php5.4.10
Chrome 28, Firefox 22, Opera 12.16, Safari 6.0.5
Mac OS X 10.7.5

Steps to reproduce:
- In a TCA multiple select field, define a "selectedListStyle" => '200px' (e.g.)

The buttons on the right of that respective select field will still keep a distance according to the default width (?).
Not a big problem, but for the sake of completeness I thought I'd mention it.


Files

TCA_selectedListStyle_withh_StaticInfoTables.png (12.7 KB) TCA_selectedListStyle_withh_StaticInfoTables.png Sample Screenshot of the TCA selecteListSTyle problem Gone With the Wind, 2013-08-02 09:10

Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Feature #23827: Change the layout of thumbnails and allowed file types so that they don't waste so much space anymoreClosedErnesto Baschny2010-10-22

Actions
Actions #1

Updated by Gone With the Wind over 10 years ago

(Sorry, the width of selectedListItem in the screenshot is actually 150px.)

Actions #2

Updated by Gerrit Code Review over 10 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/23391

Actions #3

Updated by Ernesto Baschny over 10 years ago

  • Assignee changed from Gone With the Wind to Ernesto Baschny
  • Target version changed from 6.2.0 to next-patchlevel

This is indeed a cosmetic bug since 4.5, but also related is a HTML nesting error due to a wrong parenthesis in the condition.

The problem comes from a row of "filetypes" which is always rendered below the select list with a width of hardcoded "250px" always, regardless if there is content or not.

See patch in review for a possible solution.

Actions #4

Updated by Gerrit Code Review over 10 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/23391

Actions #5

Updated by Gerrit Code Review over 10 years ago

Patch set 1 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/23474

Actions #6

Updated by Gerrit Code Review over 10 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/23475

Actions #7

Updated by Ernesto Baschny over 10 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #8

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF