Bug #50872

File permissions set in the user record are not taken into account

Added by Helmut Hummel over 8 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2013-08-07
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

With FAL a new way to define file permissions (for storages) has been introduced.
You can set these in User TsConfig instead of doing it in the user record.

There is a backwards compatibility layer however which should
set the permissions according to the database entry in case no
permissions have been set in TsConfig does not work,
because of a wrong check for existence of UserTsConfig properties.

Instead of checking for an array (which is always the case), we
have to check if the array is not empty.

#1

Updated by Gerrit Code Review over 8 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/22921

#2

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/22929

#3

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/22930

#4

Updated by Helmut Hummel over 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#5

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF