Bug #51265

Page module: "Clickmenu is not defined" JS Error

Added by Urs Braem over 8 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2013-08-22
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.1
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

In TYPO3 6.1.29, under certain circumstances (I don't know which, it happens in one instance and in another it doesn't), the "new item" icon won't appear in the page module. AND there's no drag & dropping of content items.

In the instance with the error, I get this js error message:

Uncaught ReferenceError: Clickmenu is not defined
sysext/cms/layout/db_layout.php?id=10:167

Maybe it's the same issue as mentioned in this post:
http://www.typo3.net/forum/thematik/zeige/thema/115309/
http://translate.google.com/translate?hl=de&sl=de&tl=en&u=http%3A%2F%2Fwww.typo3.net%2Fforum%2Fthematik%2Fzeige%2Fthema%2F115309%2F

Also, the css hack proposed in that post does the trick, but of course won't make the js work.


Related issues

Related to TYPO3 Core - Bug #53844: Backend JS is broken due to mistake in ResourceCompressorClosedMarkus Klein2013-11-21

Actions
#1

Updated by Urs Braem over 8 years ago

to be sure, I've uninstalled all non-system-extensions, but it wouldn't change anything

#2

Updated by Stefan Aebischer about 8 years ago

Seems to be related to #53844. The fix for the related bug will also fix this one.

#3

Updated by Stefan Neufeind almost 8 years ago

  • Status changed from New to Closed
  • Is Regression set to No

Closing this as, per the comments, we expect this is fixed with #53844 which is meanwhile resolved as well.
If you still encounter an issue, please try to make it reproducible somehow and bring it up again so we can have a look.

Also available in: Atom PDF