Bug #52770

Cannot create page titles with accented chars

Added by Jean-Sébastien Gervais about 5 years ago. Updated 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2013-10-14
Due date:
% Done:

0%

TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Using a new TYPO3 4.5.30 instance, I was unable to create or update page titles with accented chars (e.g. «Politique de confidentialité»), resulting in blank titles in the pagetree.

On first observation, the bug seems to be caused by a javascript exception when saving the page :

Uncaught Element.alignToXY with an element that doesn't exist ext-all-9bd37e475b4a7eb17e81d7861fd568f3.js:7
Ext.Element.addMethods.getAlignToXY ext-all-9bd37e475b4a7eb17e81d7861fd568f3.js:7
Ext.ToolTip.Ext.extend.getTargetXY ext-all-9bd37e475b4a7eb17e81d7861fd568f3.js:7
Ext.ToolTip.Ext.extend.show ext-all-9bd37e475b4a7eb17e81d7861fd568f3.js:7
(anonymous function)

I'm using Chrome in ubuntu 12.04; TYPO3 instance is hosted on a Centos 6

History

#1 Updated by Jean-Sébastien Gervais about 5 years ago

Same issue under firefox

#2 Updated by Jean-Sébastien Gervais about 5 years ago

I was able to fix it by enforcing
*[BE][forceCharset] = utf-8 *

in the install tool.

The notice «NOTICE: This option is deprecated since TYPO3 4.5, and will be removed in 4.7. Please use proper tools to set your installation to native UTF-8.» was but misleading.

#3 Updated by Georg Ringer about 4 years ago

  • Status changed from New to Resolved

issue has been resolved, therefore I am closing the issue.

#4 Updated by Benni Mack 2 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF