Bug #52823

cache_classes cache crashes

Added by Stefan Froemken over 7 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Caching
Target version:
Start date:
2013-10-14
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hello Core-Team,

with your new implementation of cache_classes you have crashed extbase. If form has Errors (Validators) extbase calls the errorAction. When calling:

$referringRequest->getControllerActionName();

I get following error in FE:

Fatal error: Cannot redeclare class TYPO3\Sfvalidator\Controller\PersonController in /Applications/MAMP/htdocs/typo3_git/typo3conf/ext/sfvalidator/Classes/Controller/PersonController.php on line 107

If I debug within getControllerActionName the name was resolved correctly. But when I debug getControllerActionName in Request-Object then I get the error with redeclaration. There seems to be some magic I don't understand. Maybe it is because of "new" in getReferringRequest()?!

Stefan

#1

Updated by Gerrit Code Review over 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/24787

#2

Updated by Gerrit Code Review over 7 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/24787

#3

Updated by Gerrit Code Review over 7 years ago

Patch set 1 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/24788

#4

Updated by Gerrit Code Review over 7 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/24789

#5

Updated by Thomas Maroschik over 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#6

Updated by Gerrit Code Review over 7 years ago

  • Status changed from Resolved to Under Review

Patch set 2 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/24788

#7

Updated by Gerrit Code Review over 7 years ago

Patch set 2 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/24789

#8

Updated by Thomas Maroschik over 7 years ago

  • Status changed from Under Review to Resolved
#9

Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF