Bug #52845

Moving folders fails

Added by Oliver Hader about 6 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2013-10-15
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

On moving existing folders inside another existing folder in the file-module, the following exception is thrown:
#1314085991: uid of Storage has to be numeric.

The reason is obvious, since the submitted storage key contains the storage object instead of the UID of the storage.


Related issues

Related to TYPO3 Core - Task #49332: FAL uses redundant try/catch statement Closed 2013-06-21

Associated revisions

Revision 07d21a59 (diff)
Added by Oliver Hader about 6 years ago

[BUGFIX] Moving folders fails

On moving existing folders inside another existing folder in the
file-module, the following exception is thrown:

1314085991: uid of Storage has to be numeric.

The reason is obvious, since the submitted storage key contains
the storage object instead of the UID of the storage.

Change-Id: Ia6f6af5252880a7bde8a537bc9e343c392eadbf5
Fixes: #52845
Releases: 6.0, 6.1, 6.2
Reviewed-on: https://review.typo3.org/24792
Reviewed-by: Xavier Perseguers
Reviewed-by: Frans Saris
Tested-by: Frans Saris
Reviewed-by: Wouter Wolters
Reviewed-by: Stefan Neufeind
Tested-by: Stefan Neufeind

Revision 693b575d (diff)
Added by Oliver Hader about 6 years ago

[BUGFIX] Moving folders fails

On moving existing folders inside another existing folder in the
file-module, the following exception is thrown:

1314085991: uid of Storage has to be numeric.

The reason is obvious, since the submitted storage key contains
the storage object instead of the UID of the storage.

Change-Id: Ia6f6af5252880a7bde8a537bc9e343c392eadbf5
Fixes: #52845
Releases: 6.0, 6.1, 6.2
Reviewed-on: https://review.typo3.org/24801
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

Revision 17618508 (diff)
Added by Oliver Hader about 6 years ago

[BUGFIX] Moving folders fails

On moving existing folders inside another existing folder in the
file-module, the following exception is thrown:

1314085991: uid of Storage has to be numeric.

The reason is obvious, since the submitted storage key contains
the storage object instead of the UID of the storage.

Change-Id: Ia6f6af5252880a7bde8a537bc9e343c392eadbf5
Fixes: #52845
Releases: 6.0, 6.1, 6.2
Reviewed-on: https://review.typo3.org/24800
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

History

#2 Updated by Gerrit Code Review about 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/24792

#3 Updated by Gerrit Code Review about 6 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/24792

#4 Updated by Oliver Hader about 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Gerrit Code Review about 6 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/24800

#6 Updated by Gerrit Code Review about 6 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/24801

#7 Updated by Oliver Hader about 6 years ago

  • Status changed from Under Review to Resolved

#8 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF