Bug #53320

Migration of some files breaks Installtool

Added by Stefan Froemken over 7 years ago. Updated over 6 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
Start date:
2013-11-04
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

Hello Core-Team,

I get following message in Installtool (Migrate tt_content.image, page.media):

The system detected a fatal error during script execution and redirected to this module. 

90% of our files were moved (rename) to the new location. The rest is still in /uploads/pics/. After debugging it seems that this line breaks:

$file = $this->storage->getFile($fieldConfiguration['targetPath'] . $item);

I don't know why because you have a check on $sourcePath above which continues loop on error. After catching for \Exception on this line and set $file to NULL on error, the migration script works again. But in my opinion it seems the error is elsewhere.

Stefan

#1

Updated by Gerrit Code Review over 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25159

#2

Updated by Wouter Wolters over 6 years ago

  • Status changed from Under Review to Rejected

This has been resolved in a different way already for 6.2

Also available in: Atom PDF