Bug #53567

sys_file.metadata does not use TCA type inline

Added by Oliver Hader about 6 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2013-11-12
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

The field sys_file.metadata defines the TCA property "foreign_field" that is only defined for the TCA type "inline". Using "foreign_field" with the select type does not make much sense, since select elements can be seen as m:n reference that is persisted with each parent record and thus could have multiple parents.


Related issues

Precedes TYPO3 Core - Bug #52630: PlaceHolder Feature in TCEforms only works on first relation level Closed 2013-11-13 2013-11-13

Associated revisions

Revision 0796c6d4 (diff)
Added by Oliver Hader about 6 years ago

[BUGFIX] sys_file.metadata does not use TCA type inline

The field sys_file.metadata defines the TCA property
"foreign_field" that is only defined for the TCA type "inline".
Using "foreign_field" with the select type does not make much
sense, since select elements can be seen as m:n reference that
is persisted with each parent record and thus could have
multiple parents.

Fixes: #53567
Releases: 6.2
Change-Id: I2c8e12b6343275d7f38853ba25ac6a0427c13dbd
Reviewed-on: https://review.typo3.org/25320
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

History

#1 Updated by Gerrit Code Review about 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25320

#2 Updated by Oliver Hader about 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF