Bug #53594

No placeholder attribute in backend forms

Added by Oliver Hader almost 6 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2013-11-13
Due date:
% Done:

100%

TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The disposal of the placeholder feature in backend forms needs to be enabled using the mode setting "useOrOverridePlaceholder" in TCA. However, the implementation for checking this needs to be inverted, since it returns an empty string if it's enabled, but should be the opposite way instead.

How to reproduce:
  • enter a title for a file in the file backend module
  • create a new content element (text w/image) and assign that file
  • after enabling the override mode, the input field should show the placeholder (using the HTML5 placeholder attribute)

How it should look like (but does not currently):

53594.png View (8.59 KB) Oliver Hader, 2013-11-13 10:43


Related issues

Related to TYPO3 Core - Bug #53573: FormDataTraverser::getFieldValueRecursive() might return NULL Closed 2013-11-12

Associated revisions

Revision c631a58f (diff)
Added by Oliver Hader almost 6 years ago

[BUGFIX] No placeholder attribute in backend forms

The disposal of the placeholder feature in backend forms needs
to be enabled using the mode setting "useOrOverridePlaceholder"
in TCA. However, the implementation for checking this needs to
be inverted, since it returns an empty string if it's enabled,
but should be the opposite way instead.

Fixes: #53594
Releases: 6.2, 6.1, 6.0
Change-Id: I3d3fe5ac76c05f4601860c79d7f514bffea13963
Reviewed-on: https://review.typo3.org/25365
Reviewed-by: Markus Klein
Tested-by: Markus Klein
Reviewed-by: Wouter Wolters
Tested-by: Wouter Wolters

History

#1 Updated by Oliver Hader almost 6 years ago

#2 Updated by Gerrit Code Review almost 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25365

#3 Updated by Gerrit Code Review almost 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25365

#4 Updated by Gerrit Code Review almost 6 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25365

#5 Updated by Oliver Hader almost 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF