Bug #53658

Remove "alternateBgColors"

Added by Wouter Wolters almost 6 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2013-11-15
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hi,

The subject works but is marked as not working. We only did a small fix for the hovering. see https://review.typo3.org/#/c/25409/

Associated revisions

Revision f30b4dde (diff)
Added by Wouter Wolters almost 5 years ago

[!!!][TASK] Remove alternateBgColors option

Resolves: #53658
Releases: master
Change-Id: If36c17741d8f3a9a07f7cc8ad2f3289164b8b195
Reviewed-on: http://review.typo3.org/33831
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>
Reviewed-by: Stefan Froemken <>
Tested-by: Stefan Froemken <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

History

#1 Updated by Chris topher over 5 years ago

  • Project changed from TSconfig to TYPO3 Core

Hi Wouter,

when we changed the docs to say "has been removed" the problem with this option was that it in fact did no longer do what is was supposed to.

With alternateBgColors = 1 you do get alternating colors. However, with alternateBgColors = 0 you should then be able to switch alternation off - that also is what the description in TSconfig tells you and what was possible in older versions. But in current versions you can't anymore! Switching alternation off effectively was removed. Rows are alternating anyway; whether alternateBgColors is set or not. The only difference is that the colors are a bit different when it's set compared to when it's not set - but alternation is there always. If I remember correctly it was a decision by the UI team that alternation should always be there. So basically it does not make sense to tell people that there would be an option to switch alternation off - rows will alternate anyway and that is what is wanted. This option - at least with that name - does not make sense anymore.

Two possible solutions: Either make the property really turn alternation off again (the UI team does not want that) or finally really remove this property (this is what the UI team wants, what the docs claim had been done since ages and what effectively also has been done already).

The right solution is to remove alternateBgColors.

(Offtopic: Maybe you say that you want to have two different sets of alternation, e.g. one with higher contrast for people who want/need that (the patch you linked to reads like that). I have absolutely no problem with that, but then please use another property name for that, e.g. alternateHighContrast or something like that.)

#2 Updated by Chris topher over 5 years ago

  • Subject changed from alternateBgColors = 1 works but is marked as not working to Remove "alternateBgColors"
  • PHP Version set to 5.5
  • Is Regression set to No
  • TYPO3 Version set to 6.2

#3 Updated by Gerrit Code Review almost 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33831

#4 Updated by Gerrit Code Review almost 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33831

#5 Updated by Gerrit Code Review almost 5 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33831

#6 Updated by Wouter Wolters almost 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF