Bug #54191

ext_autoload was not loaded from Cache

Added by Stefan Froemken over 7 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Caching
Target version:
Start date:
2013-12-04
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

Hello Core-Team,

only ext_autoload from early classes were saved in cache. So after calling loadPackageNamespacesFromCache only entries of the early classes were loaded. All entries for direct_mail, solr and other extensions aren't there.
To build these entries you have a method called: buildClassInformationsFromFullAutoloadRegistry. But this will only be called if cache is empty.

Stefan


Related issues

Is duplicate of TYPO3 Core - Bug #53929: Class loader does not respect ext_autload.phpClosed2013-11-25

Actions
#1

Updated by Gerrit Code Review over 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25935

#2

Updated by Gerrit Code Review over 7 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25935

#3

Updated by Helmut Hummel about 7 years ago

  • Status changed from Under Review to Closed

resolved with this one: https://review.typo3.org/24939

Also available in: Atom PDF