Bug #54299

Flexform - type group, folder - Uncaught TYPO3 Exception

Added by Peter Benke over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2013-12-10
Due date:
% Done:

0%

TYPO3 Version:
6.1
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hi all,

I have the following element in a flexform:

<type>group</type>
<internal_type>folder</internal_type>
<size>1</size>
<minitems>0</minitems>
<maxitems>1</maxitems>

If I click on the folder-icon in the backend, I get the following message:

Uncaught TYPO3 Exception
#1: PHP Catchable Fatal Error: Argument 1 passed to TYPO3\CMS\Recordlist\Browser\ElementBrowser::TBE_expandSubFolders() must be an instance of TYPO3\CMS\Core\Resource\Folder, null given, called in [My-Document-Root]\typo3\sysext\recordlist\Classes\Browser\ElementBrowser.php on line 1278 and defined in [My-Document-Root]\typo3\sysext\recordlist\Classes\Browser\ElementBrowser.php line 1453 (More information)

TYPO3\CMS\Core\Error\Exception thrown in file
[My-Document-Root]\typo3\sysext\core\Classes\Error\ErrorHandler.php in line 108.

Version: TYPO3 6.1.6

Thank you!
Peter


Related issues

Duplicates TYPO3 Core - Bug #43504: Flexform internal_type=folder doesn't work and breaks Element Browser Closed 2012-12-01

History

#1 Updated by Markus Klein over 6 years ago

  • Status changed from New to Closed

Closing as duplicate of #43504.
Please continue there.

Also available in: Atom PDF