Bug #54510

phpunit run in Travis: Detect and fix memory leaks

Added by Ernesto Baschny almost 6 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Tests
Target version:
-
Start date:
2013-12-19
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Travis with PHP 5.3 is requiring more than 1 GB of RAM in one run since some merge and then the PHP run fails.

Instead of constantly increase the memory_limit when this occurs, we should investigate what exactly takes so much memory and limit that so that the test-run scales better.

History

#1 Updated by Mathias Schreiber over 4 years ago

  • Status changed from New to Resolved

#2 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF