Bug #55024

Bring back final class name cache

Added by Helmut Hummel almost 6 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
2014-01-15
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The class name needs to be determined through
a lookup in the implementation configuration
(AKA XCLASS).
This runtime cache was removed in favor of
a cache in the class loader. But this caching
behavior also changed due to the package management
API implementation.

Associated revisions

Revision 5ecb43f7 (diff)
Added by Helmut Hummel almost 6 years ago

[BUGFIX] Bring back final class name cache

The class name needs to be determined through
a lookup in the implementation configuration
(AKA XCLASS).

This runtime cache was removed in favor of
a cache in the class loader. But this caching
behavior also changed due to the package management
API implementation.

Releases: 6.2
Resolves: #55024
Change-Id: I8dc101c0c04c88e531907fcfaf82e529af483e01
Reviewed-on: https://review.typo3.org/26821
Reviewed-by: Steffen Ritter
Tested-by: Steffen Ritter

History

#1 Updated by Gerrit Code Review almost 6 years ago

  • Status changed from New to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/26821

#2 Updated by Helmut Hummel almost 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF