Project

General

Profile

Actions

Bug #55320

closed

Database records list pagination issue with recordsPerPage=1

Added by Marcin Sągol about 10 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend API
Target version:
Start date:
2014-01-25
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

If we set recordsPerPage to 1 for pagination in DatabaseRecordsList for example through

/typo3/sysext/fluid/Classes/ViewHelpers/Be/TableListViewHelper.php

then pointers in pagination links are generated wrong. We can switch forward but missing every second record so pagination jumps to page 1 -> 3 -> 5 etc.
and than we can't jumb back because of wrong pointers calculated.

Actions #1

Updated by Markus Klein almost 10 years ago

  • Status changed from New to Accepted
  • Priority changed from Should have to Must have
  • Target version changed from 6.2.0 to next-patchlevel
  • Complexity set to easy

Testable by entering

$GLOBALS['TCA']['pages']['interface']['maxSingleDBListItems'] = 1;

into extTables.php

Go to single table view for pages in list module.

Actions #2

Updated by Gerrit Code Review almost 10 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29949

Actions #3

Updated by Gerrit Code Review almost 10 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29949

Actions #4

Updated by Markus Klein over 9 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #5

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF