Bug #55373

Extension manager installs (activates) extensions automatically

Added by Paul A. Auwehla over 8 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Extension Manager
Target version:
Start date:
2014-01-27
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.1
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Ext Manager 6.1.0 in typo3 still is not just fetching but still directly installs new extensions without asking.
This is annoying and should not be the default in stable versions of typo3.

But:
Much, much more annoying is that ext. manager INSTALLS deactivated(!)
extensions when on UPDATING them.

This is not a feature - this is a more than serious bug in my opinion.

(Reported by user against TYPO3 6.1.7.)


Related issues

Is duplicate of TYPO3 Core - Feature #50501: The ability to just import/fetch/download an extension from the TER without installing it.Closed2013-07-28

Actions
#1

Updated by Stefan Neufeind about 8 years ago

  • Subject changed from extension manager 6.1.0 in typo 6.1.7 to Extension manager installs (activates) extensions automatically
#2

Updated by Susanne Moog almost 8 years ago

Hi,

a feature for some - a bug for some others. As there are use cases for both behaviors, we don't want to switch back to the old behavior, but give users the possibility to change the behavior. See issue #50501 for some more information and a patch. If you want to, you can test the patch and give feedback there.

Meanwhile I'll close this ticket as a duplicate.

Thanks and regards,

susi

#3

Updated by Susanne Moog almost 8 years ago

  • Status changed from New to Closed

Also available in: Atom PDF