Bug #55466

Don't show upload form if user has no rights to defaultUploadFolder

Added by Stefan Froemken over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2014-01-30
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

Hello Core-Team,

if you have a newly created BE-User who opens the element browser the first time, the defaultUploadFolder will be retrieved from Storage which is "user_upload". If user has only defined filemounts to "user_upload/news/" or whatever, he gets a ""-message in element browser. It would be good to hide upload form as long as the user has no rights to access defaultUploadFolder.

Stefan


Related issues

Is duplicate of TYPO3 Core - Bug #55439: Default upload folder not accessible for editorsClosed2014-01-29

Actions
Blocks TYPO3 Core - Story #54267: As an Editor I want to use a FAL withouth bugsClosed2013-01-15

Actions
#1

Updated by Gerrit Code Review over 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27153

#2

Updated by Ingo Schmitt over 7 years ago

  • Status changed from Under Review to Closed

Also available in: Atom PDF