Bug #55545

File upload directly in Doc-module is missing

Added by Frans Saris almost 6 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2014-02-01
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Since the introductions of FAL the option to upload files directly in T3form is missing.

As this is a functionality used by a lot of editors it should be added again.
Preferably with drag&drop upload and a nice progress indicator.


Related issues

Related to TYPO3 Core - Bug #56018: Adding new IRRE element does strange things to the layout in chrome/chromium Closed 2014-02-16
Related to TYPO3 Core - Bug #63286: Cannot disable direct file upload via "Select & upload files" Closed 2014-11-24

Associated revisions

Revision 56a96782 (diff)
Added by Frans Saris almost 6 years ago

[BUGFIX] File upload directly in Doc-module is missing

Since the introduction of FAL the option to upload a file
directly in your form has disappeared.

With this change the upload posibility is back with some extras.
  • progress is shown
  • drag&drop of files
  • multiple file upload

The options is can be disabled just like before in the
user settings and for each field in TCA.

foreign_selector_fieldTcaOverride.config.appearance.fileUploadAllowed = 0

The upload button is only shown for browsers that support
drag&drop upload. And only for FAL fields (sys_file_reference).

Resolves: #55545
Releases: 6.2
Change-Id: I4b984099095d7f66c3d37023cd6c547b2ff5d59f
Reviewed-on: https://review.typo3.org/27237
Reviewed-by: Benjamin Mack
Tested-by: Benjamin Mack

History

#1 Updated by Gerrit Code Review almost 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27237

#2 Updated by Gerrit Code Review almost 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27237

#3 Updated by Gerrit Code Review almost 6 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27237

#4 Updated by Frans Saris almost 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF