Bug #55645

Add wizard redirects to original form if PID larger zero

Added by Alexander Stehlik over 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
Start date:
2014-02-04
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
easy
Is Regression:
Yes
Sprint Focus:

Description

The add_wizard.php script will always redirect the user back to the original form if a PID larger than zero is used.

This bug was introduced with https://review.typo3.org/25843/ because an invalid condition is used:

if ($this->pid > 0) {
    HttpUtility::redirect(GeneralUtility::sanitizeLocalUrl($this->P['returnUrl']));
}

should be

if ($this->pid !== '') {
    HttpUtility::redirect(GeneralUtility::sanitizeLocalUrl($this->P['returnUrl']));
}

which it was before.

History

#1 Updated by Alexander Stehlik over 6 years ago

Sorry, I mean

$this->pid === ''

#2 Updated by Gerrit Code Review over 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27316

#3 Updated by Wouter Wolters about 6 years ago

  • Status changed from Under Review to Closed

Also available in: Atom PDF