Bug #55766

PHP Catchable Fatal Error: Object of class TYPO3\CMS\Core\Resource\Folder could not be converted to string in LocalDriver.php line 677

Added by Frans Saris over 7 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
-
Target version:
Start date:
2014-02-07
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
no-brainer
Is Regression:
No
Sprint Focus:

Description

When you use storage->addFile() with conflictMode='changeName' you run in to the following fatal error when there is already a file with that name:

PHP Catchable Fatal Error: Object of class TYPO3\CMS\Core\Resource\Folder could not be converted to string in typo3/sysext/core/Classes/Resource/Driver/LocalDriver.php line 677

Related issues

Is duplicate of TYPO3 Core - Bug #55763: using object as string in ResourceStorage->getUniqueName ClosedTymoteusz Motylewski2014-02-07

Actions
#1

Updated by Gerrit Code Review over 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27417

#2

Updated by Tymoteusz Motylewski over 7 years ago

Hi Frans,
Thanks for the patch, unfortunately it's a duplicate of the issue #55763, which also have a patch.
Would you mind voting here: https://review.typo3.org/#/c/27412/
then we can close this issue, and merge the original one.
Thanks!
Tymoteusz

#3

Updated by Tymoteusz Motylewski over 7 years ago

  • Status changed from Under Review to Resolved
#4

Updated by Benni Mack almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF