Bug #55932

addToAllTCAtypes inserts string twice

Added by Alexander Stehlik over 6 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Target version:
Start date:
2014-02-12
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
medium
Is Regression:
No
Sprint Focus:

Description

The problem occurs, if there there are two fields that start with the same name (e.g in current tt_content, the palettes "uploads" and and "uploadslayout") and comes from the Regex in:

ExtensionManagementUtility::executePositionedStringInsertion()

Related issues

Related to TYPO3 Core - Bug #56080: Title field gets lost after using addToAllTCAtypes Closed 2014-02-18

Associated revisions

Revision 6c973b87 (diff)
Added by Alexander Stehlik over 6 years ago

[BUGFIX] No duplicate insertion in addToAllTCAtypes

This patch improves the regular expression in
ExtensionManagementUtility::executePositionedStringInsertion().

It is made sure that the field name ends with a comma or a line
ending to prevent duplicate insertions of the string when field
names start with the same substring.

Resolves: #55932
Releases: 6.2
Change-Id: I375c40760a38b7f939086bb851911bd7f52509ca
Reviewed-on: https://review.typo3.org/27583
Reviewed-by: Michiel Roos
Tested-by: Michiel Roos
Reviewed-by: Markus Klein
Tested-by: Markus Klein

History

#1 Updated by Gerrit Code Review over 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27583

#2 Updated by Thomas Skierlo over 6 years ago

Can this be related to #55802? Getting all subheader 3-4 times in BE forms since February 6.

#3 Updated by Alexander Stehlik over 6 years ago

Could be, Thomas. Would be great if you could test if the patch fixes the problem for you.

#4 Updated by Thomas Skierlo over 6 years ago

Can confirm: Patch solves #55802 as well. Great Job!

#5 Updated by Alexander Stehlik over 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF