Project

General

Profile

Actions

Bug #56494

closed

FAL readonly: Directory copying results in BE exception

Added by Rico Sonntag almost 10 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2014-03-03
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Trying to copy a readonly directory to another directory results in an backend exception displayed. This is caused because ExtendedFileUtility.php just catches InsufficientFolderAccessPermissionsException but InsufficientFolderReadPermissionsException and InsufficientFolderWritePermissionsException are not derived from it.

Actions #1

Updated by Gerrit Code Review almost 10 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27994

Actions #2

Updated by Christian Weiske almost 10 years ago

Steps to reproduce:
  1. Create readonly FAL storage
  2. Copy one folder of the readonly FAL storage into another folder of the readonly FAL storage
  3. An uncaught exception occurs
Actions #3

Updated by Rico Sonntag almost 10 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #4

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF