Bug #56532

PackageState.php gets rewritten on every ExtensionManager call (InvalidPackageKeyException)

Added by Alexander Opitz over 5 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Category:
Extension Manager
Target version:
Start date:
2014-03-04
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

See comment from Ernesto in https://review.typo3.org/#/c/27024/ Mar 4 2:02 PM

From chat:

laut debugger läuft er da rein weil er in "registerPackagesFromConfiguration" auf das hier stößt:
    } catch (\TYPO3\Flow\Package\Exception\InvalidPackageKeyException $exception) {
    $this->unregisterPackageByPackageKey($packageKey);
    continue;
   }

Translation:

according to debugger it runs into this, because it hits the following in "registerPackagesFromConfiguration":
    } catch (\TYPO3\Flow\Package\Exception\InvalidPackageKeyException $exception) {
    $this->unregisterPackageByPackageKey($packageKey);
    continue;
   }


Related issues

Related to TYPO3 Core - Bug #55252: PHP 5.5 and require LocalConfiguration Closed 2014-01-22

Associated revisions

Revision d24ae450 (diff)
Added by Daniel Siepmann over 5 years ago

[BUGFIX] Only valid package names will be processed.

To prevent the extension manager from further steps while
invalid package keys exists in the system, the package keys are
validated earlier.

This prevents further actions that will lead to rewrite
of PackageState.php and invalid opcode cache.

Change-Id: Ib8d9f25dc1d6c97b94a59b15255b96d5a1960093
Resolves: #56532
Releases: 6.2
Reviewed-on: https://review.typo3.org/28286
Reviewed-by: Steffen Ritter
Tested-by: Steffen Ritter

History

#1 Updated by Daniel Siepmann over 5 years ago

  • Category set to Extension Manager
  • Assignee set to Daniel Siepmann

#2 Updated by Daniel Siepmann over 5 years ago

The problem is that all packageKeys are added during testing if new are available. But invalid keys are skipped on write.

So the test for validate package keys should be done even while getting all package keys from file system.

#3 Updated by Gerrit Code Review over 5 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28286

#4 Updated by Gerrit Code Review over 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28286

#5 Updated by Daniel Siepmann over 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF