Bug #56884

File Upload (images) in Page Ressources, missing alt- and title tag

Added by Marc Fell over 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2014-03-13
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

it should be possible to have "title" and "alt" tag on images everywhere

otherwise the file is irrelevant to use these images in the frontend because of missing SEO features


Files

2.PNG (21.7 KB) 2.PNG Marc Fell, 2014-03-13 20:06
7654dummy2.jpg (104 KB) 7654dummy2.jpg Marc Fell, 2014-03-15 18:31
Unbenannt.PNG (24.6 KB) Unbenannt.PNG Marc Fell, 2014-03-15 18:31

Related issues

Related to TYPO3 Core - Bug #77541: Lost Page media after translation and at news media Image-Editor (Crop) is missingClosed2016-08-18

Actions
#1

Updated by Frans Saris over 7 years ago

  • Status changed from New to Needs Feedback

Hi Marc,

It is posible to set these fields. Just check the override checkbox or do you mean something else?

#2

Updated by Marc Fell over 7 years ago

Hi Frans,

the options for "title" and "description" are ok.

What's missing:
- "link"
- "alt tag"

-> four options are needed for each image ... two options are missing

#3

Updated by Frans Saris over 7 years ago

Looks like typo3 doesn't recognise your file as an image, these fields are only shown when the file is an image if I am not mistaken. Did you try other files? Maybe with lowecase extension name?

#4

Updated by Marc Fell over 7 years ago

I tried is again with a very common image ... nothing special ... again: no alt tag, no link

I can give you an admin login, if this is helpful for you:

#5

Updated by Marc Fell about 7 years ago

... just checked this issue with 6.2.0rc1 - still no "alt tag" and no "link" for images.

I know, there ist still a lot work to do, but having images without these fields is ... hmm ...

#6

Updated by Frans Saris about 7 years ago

Totaly forgot about this. Will have a look at it on monday

#7

Updated by Marc Fell about 7 years ago

Thank you!

I don't want to make any pressure on you ... but I think, this is important to be done.

#8

Updated by Frans Saris about 7 years ago

Hi Marc,

I had already a look at this. Seems that these fields are not set to be shown on this place. I currently trying to find out if this is intended.

You can easily extend the TCA to get these field visible have a look ad TCA/tt_content.php and then the image column definition.

gr. Frans

--
This is how the media column in pages.php should look like to get the extra fields

        'media' => array(
            'exclude' => 1,
            'label' => 'LLL:EXT:cms/locallang_tca.xlf:pages.media',
            'config' => \TYPO3\CMS\Core\Utility\ExtensionManagementUtility::getFileFieldTCAConfig('media', array(
                // custom configuration for displaying fields in the overlay/reference table
                // to use the imageoverlayPalette instead of the basicoverlayPalette
                'foreign_types' => array(
                    '0' => array(
                        'showitem' => '
                            --palette--;LLL:EXT:lang/locallang_tca.xlf:sys_file_reference.imageoverlayPalette;imageoverlayPalette,
                            --palette--;;filePalette'
                    ),
                    \TYPO3\CMS\Core\Resource\File::FILETYPE_TEXT => array(
                        'showitem' => '
                            --palette--;LLL:EXT:lang/locallang_tca.xlf:sys_file_reference.imageoverlayPalette;imageoverlayPalette,
                            --palette--;;filePalette'
                    ),
                    \TYPO3\CMS\Core\Resource\File::FILETYPE_IMAGE => array(
                        'showitem' => '
                            --palette--;LLL:EXT:lang/locallang_tca.xlf:sys_file_reference.imageoverlayPalette;imageoverlayPalette,
                            --palette--;;filePalette'
                    ),
                    \TYPO3\CMS\Core\Resource\File::FILETYPE_AUDIO => array(
                        'showitem' => '
                            --palette--;LLL:EXT:lang/locallang_tca.xlf:sys_file_reference.imageoverlayPalette;imageoverlayPalette,
                            --palette--;;filePalette'
                    ),
                    \TYPO3\CMS\Core\Resource\File::FILETYPE_VIDEO => array(
                        'showitem' => '
                            --palette--;LLL:EXT:lang/locallang_tca.xlf:sys_file_reference.imageoverlayPalette;imageoverlayPalette,
                            --palette--;;filePalette'
                    ),
                    \TYPO3\CMS\Core\Resource\File::FILETYPE_APPLICATION => array(
                        'showitem' => '
                            --palette--;LLL:EXT:lang/locallang_tca.xlf:sys_file_reference.imageoverlayPalette;imageoverlayPalette,
                            --palette--;;filePalette'
                    )
                )
            )
        )

#9

Updated by Marc Fell about 7 years ago

Perfect, THX!

#10

Updated by Marc Fell about 7 years ago

Servus Frans,

is there a chance to get this solved in 6.2.2?

#11

Updated by Gerrit Code Review about 7 years ago

  • Status changed from Needs Feedback to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29816

#12

Updated by Frans Saris about 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#13

Updated by Frans Saris about 7 years ago

@Marc, tnx for the reminder.

Change is merged.

#14

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF