Bug #57038

Cannot install 6.2 beta7 anymore from GIT

Added by d.ros no-lastname-given over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2014-03-18
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Since today I face:

Fatal error: Uncaught exception 'RuntimeException' with message 'Could not acquire lock for ClassLoader cache creation.' in /var/www/web1/html/subdomains/playground_62/TYPO3.CMS/typo3/sysext/core/Classes/Core/ClassLoader.php:704 Stack trace: #0 /var/www/web1/html/subdomains/playground_62/TYPO3.CMS/typo3/sysext/core/Classes/Core/ClassLoader.php(230): TYPO3\CMS\Core\Core\ClassLoader->acquireLock() #1 /var/www/web1/html/subdomains/playground_62/TYPO3.CMS/typo3/sysext/core/Classes/Core/ClassLoader.php(171): TYPO3\CMS\Core\Core\ClassLoader->buildCachedClassLoadingInformation('typo3_cms_core_...', 'TYPO3\CMS\Core\...') #2 [internal function]: TYPO3\CMS\Core\Core\ClassLoader->loadClass('TYPO3\CMS\Core\...') #3 /var/www/web1/html/subdomains/playground_62/TYPO3.CMS/typo3/sysext/core/Classes/Core/Bootstrap.php(313): spl_autoload_call('TYPO3\CMS\Core\...') #4 /var/www/web1/html/subdomains/playground_62/TYPO3.CMS/typo3/sysext/core/Classes/Core/Bootstrap.php(233): TYPO3\CMS\Core\Core\Bootstrap->initializePackageManagement('TYPO3\CMS\C in /var/www/web1/html/subdomains/playground_62/TYPO3.CMS/typo3/sysext/core/Classes/Core/ClassLoader.php on line 704

after calling ~/typo3/install on a fresh git install with:

wdir=~/html/subdomains/playground_62/

cd $wdir

git clone git://git.typo3.org/Packages/TYPO3.CMS.git --depth 1

ln -s TYPO3.CMS typo3_src
ln -s typo3_src/index.php
ln -s typo3_src/typo3

find . -type f -exec chmod 644 {} \;
find . -type d -exec chmod 755 {} \;

running on master branch seeing only commit 1e2598a0c99e53eca21b693c7dfd7e712891ed96 from 10.03.2014

git log
commit 1e2598a0c99e53eca21b693c7dfd7e712891ed96
Author: Alexander Stehlik <alexander.stehlik@googlemail.com>
Date:   Mon Mar 10 10:00:39 2014 +0100

when pushing

git history

but should be something more recent.

also a rebase fails to update as with

git rebase master
Current branch master is up to date.

I put it to "Install Tool" as it is a kind of installation task.


Related issues

Is duplicate of TYPO3 Core - Bug #57008: New Installation: Could not acquire lock for ClassLoaderClosed2014-03-17

Actions
#1

Updated by d.ros no-lastname-given over 7 years ago

  1. Correction

the commit seems to be OK. Just had an eye on the creation date. Not on the commit date.

But the error remains.

#2

Updated by d.ros no-lastname-given over 7 years ago

  1. psuhing a checkout solves this

git checkout TYPO3_6-2-0beta7

#3

Updated by Markus Klein over 7 years ago

  • Status changed from New to Closed

Duplicates #57008

#4

Updated by Markus Klein over 7 years ago

  • Target version deleted (next-patchlevel)

Also available in: Atom PDF